Welcome to Pursuit Boats Owners Forum

We are a boating forum for owners of Pursuit Boats to enthusiastically discuss all aspects of Pursuit Boat ownership. Whether you are looking for your first Pursuit or currently own one, you are sure to feel at home on PursuitBoatOwners.com

You are currently viewing our boards as a guest which gives you limited access to view most discussions, articles and access our other FREE features. By joining our free community you will have access to searching the forum topics, post topics, communicate privately with other members (PM), respond to polls, upload your own photos and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

2470 WA water in front bilge after rain fall.

ImageHave a question or issue that is model specific? The is the forum to discuss general information regarding all Pursuit Boats.

Topic author
riptide
Junior Member
Posts: 1
Joined: Mon Jan 10, 2022 6:34 pm
Vessel Info: 2005 Pursuit 2470 walk around, with twin 2020 Yamaha F115 and a 2020 Yamaha 9.9

2470 WA water in front bilge after rain fall.

Postby riptide » Mon Jan 10, 2022 6:43 pm

Hello Everyone
i have a 2005 2470 and i'm getting water in my front bilge after rain storms. I cant find any obvious entry points and my cuddy cabin is dry. This is happening when the boat in on the trailer in my driveway so its not coming through hull. Any and all help will be greatly appreciated.
Thank you
Scott


saa844
Junior Member
Posts: 17
Joined: Tue Dec 25, 2012 4:27 pm
Home Port: Cutchogue Ny

2470 WA water in front bilge after rain fall.

Postby saa844 » Mon Jan 17, 2022 7:08 pm

I have the same boat. Do you have a windless maybe water is coming thru the windless opening. I just repowered with a Zuke DF300 Can you share your power/prop size? I am trying to figure out if I should use a 16x17 or 16x18.5 prop,

bestmate
Junior Member
Posts: 3
Joined: Tue Nov 03, 2020 8:02 pm
Vessel Info: 2004 2470WA

2470 WA water in front bilge after rain fall.

Postby bestmate » Tue Feb 08, 2022 7:43 pm

I have the same issue - suspect that it is the failing caulk around the thrudeck drains and the same drains in the engine well. This year project is climbing the bilge to replace (if I can find the right ones).

Return to “General Pursuit Boats Forum”



Who is online

Users browsing this forum: Bing [Bot] and 1 guest