Welcome to Pursuit Boats Owners Forum

We are a boating forum for owners of Pursuit Boats to enthusiastically discuss all aspects of Pursuit Boat ownership. Whether you are looking for your first Pursuit or currently own one, you are sure to feel at home on PursuitBoatOwners.com

You are currently viewing our boards as a guest which gives you limited access to view most discussions, articles and access our other FREE features. By joining our free community you will have access to searching the forum topics, post topics, communicate privately with other members (PM), respond to polls, upload your own photos and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

speedometer stopped working- 24.7 IO

Anything related to the operation of your boat that doesn't fit another forum category. Steering, Bilge Pumps, thru-hulls, bottom paint, etc.

Topic author
atwr
Junior Member
Posts: 11
Joined: Tue May 05, 2020 8:52 pm
Vessel Info: 1999 Denali
Been thanked: 1 time

speedometer stopped working- 24.7 IO

Postby atwr » Mon Sep 14, 2020 8:24 pm

Hello-

My speedometer on 1999 24.7 Denali, I/O Mercruiser, stopped working when cruising at 3500 RPM. No issues with engine running etc.., just lost speedometer capability.

Does anyone have any recommendations as to how to fix/ cause of issue, etc?

Thanks

Return to “General Repairs & Maintenance”



Who is online

Users browsing this forum: No registered users and 1 guest